Frage Wie aktiviert man WebGL in Chrome auf Ubuntu?


chrome://gpu/

enter image description here

Und http://webglreport.com/

enter image description here

 google-chrome --version
 Google Chrome 27.0.1453.93 

http://www.chromexperiments.com/webgl

enter image description here

Wie aktiviert man WebGL in Chrome auf Ubuntu?


109
2018-05-24 05:27


Ursprung




Antworten:


Damit WebGL in Google Chrome (und Chromium) funktioniert, hier die Schritte zum Aktivieren von WebGL in Google Chrome.

Schritt 1: Öffnen Sie Google Chrome

Schritt 2: Geben Sie ein chrome://flags in der Adressleiste

Schritt 3: Drücken Sie Ctrl + f und tippe " Rendering list ", "Software-Rendering-Liste überschreiben" sollte hochkommen, klicken Sie nun auf Aktivieren und starten Sie den Browser neu.

Schritt 4: Chrome vollständig entfernen: Geben Sie ein killall chrome in eine Konsole.

Schritt 5: Gehe zu chrome://settings und aktivieren Use hardware acceleration when available. Standardmäßig ist es seit Version 43 deaktiviert.

Schritt 6: Starten Sie Chrome

enter image description here

Jetzt prüfen chrome://gpu/

enter image description here

http://webglreport.com/

enter image description here

Quelle


148
2018-05-24 05:27



Jetzt habe ich YouTube in HTML5-Player mit schöner Leistung! - Vitaly Zdanevich
Warum ist das standardmäßig nicht aktiviert ??? - Konstantin Schubert
@Konstantin Das ist eine gute Frage, ich werde etwas darüber recherchieren. - Qasim
Tipp: Unter Ubuntu (sicher auch Windows) müssen Sie sicher sein, dass Sie auch die Hintergrund-Threads (Chrome) löschen, bevor die Änderungen wirksam werden. - Lance Caraccioli
@Kostanos nein, ich weiß nicht, dass ... das ist der einfachste Weg ... - Qasim


Wenn Sie immer noch keine Ergebnisse erhalten, überprüfen Sie, ob die Hardwarebeschleunigung in Chromium-Einstellungen aktiviert ist, Google neigt dazu, diese Einstellung standardmäßig seit Version 43 zu deaktivieren. In diesem Fall war das Problem für mich, nachdem ich die GPU-Treiber aktualisiert habe GPU-Blacklist, und so und so.


10
2017-07-11 10:57



Hier gilt das gleiche. Ich dachte, dass ich einen schrecklichen Fehler sehen würde, habe aber nicht realisiert, dass chrome: // settings -> Show advanced settings ... -> Hardwarebeschleunigung verwenden wenn irgendwie verfügbar deaktiviert wurde. Ich habe es eingeschaltet, den Browser neu gestartet und alles funktioniert. - Stephen Niedzielski
Arbeitete für mich, danke - shturm
Die Deaktivierung der Hardwarebeschleunigung funktionierte für mich. - Thomas Orlita


Verwendung von Chrom Version 49.0.2623.108 auf Ubuntu 14.04 (64-Bit).

Was wir aktivieren müssen ist #ignore-gpu-blacklist

Es ist die erste Zeile in chrome://flags/

Hoffe es kann helfen


2
2018-04-22 08:23





Vielleicht ist dein Grafiktreiber zu alt oder nicht richtig installiert.

Ich hatte das gleiche Problem, aber diese Lösung behob mein Problem ohne Overrides!

  1. PPA für Ubuntu hinzufügen 14.04 / 13.10 / 13.04 / 12.10

    Benutzer von Ubuntu 14.04 / 13.10 / 13.04 / 12.10, Führen Sie den folgenden Befehl im Terminal aus und geben Sie das Kennwort für den Benutzer ein, wenn Sie dazu aufgefordert werden. Andere benutzen das Ubuntu-X PPA.

    sudo apt-add-repository ppa: xorg-kanten / ppa
  2. PPA für Ubuntu hinzufügen 12.04 / 11.10 / 11.04 / 10.04

    sudo apt-hinzufügen-repository ppa: ubuntu-x-swat / x-updates

    Aktualisieren Sie nach dem Hinzufügen des PPA Ihr System-Repository.

  3. Aktualisieren

    sudo apt-get Aktualisierung

    Installieren Sie nun den NVIDIA GeForce Grafiktreiber 304.108 in Ihrem System, während Sie andere Pakete mit apt-get installieren.

  4. Installieren

    sudo apt-get installieren nvidia-aktuelle nvidia-einstellungen

    Der obige Befehl installiert den Treiber.


Quelle: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/


1
2017-10-22 13:04



Ich verwende diese Lösung eine Woche lang auf meinem Desktop, aber mein Chrome verbraucht manchmal alle CPUs (die Aufgabe "GPU-Prozess"). - Ich habe Ubuntu Trusty mit "GeForce 8400 GS Rev. 2" - Ich kann keine Lösung für diesen Nebeneffekt finden, nur habe ich einen Workaround: Aktivieren Sie die Option "Beschleunigte 2D-Canvas deaktivieren" in chrome: // flags / ... Grrr - andras.tim


Ich hatte das Problem, dass WebGL als nicht verfügbar gemeldet wurde nach dem Wechsel von der proprietären Nvidia zu den Nouveau-TreibernEine Änderung, die anscheinend nicht in der Chrom-GPU-Konfiguration meines Profils aufgegriffen wurde. Der Fix wird ausgeführt chromium-browser --single-process  Einmal um die GPU-Konfiguration zurückzusetzen.


0
2017-07-06 21:17