Frage Ubuntu kann nicht in VirtualBox installiert werden, da "dieser Kernel eine x86-64-CPU benötigt, aber nur einen i686-CPU erkennt, der nicht booten kann" -Fehler


Ich habe versucht, Ubuntu 12.04 in VirtualBox 4.2.12r84980 zu installieren. Aha

this kernel requires an x86-64 CPU, but only detects an i686 CPU, unable to boot

Aber ich benutze ein 64 Bit Windows 8, und versuche dasselbe .iso für Ubuntu. Was ist dann das Problem?


107
2018-06-16 17:07


Ursprung


Versuchen Sie, das 32-Bit-Ubuntu-ISO zu installieren - edwin
Es spielt keine Rolle, dass Ihr Host-System 64bit ist. Der ganze Zweck einer virtuellen Maschine ist, dass sie eine separate und autonome Maschine ist, wenn auch eine virtuelle Maschine. Bearbeiten Sie die Konfiguration der virtuellen Maschine und ändern Sie ihren CPU-Typ auf 64 Bit. - hmayag
Verbunden: Kernel benötigt eine x86-64 CPU, erkennt aber nur eine i686 CPU. Wie kann ich Lubuntu / Ubuntu installieren? - Eliah Kagan


Antworten:


Um ein 64-Bit-Betriebssystem in Virtual Box ausführen zu können, müssen wir sicherstellen, dass die Architektur der virtuellen Maschine ebenfalls auf 64-Bit eingestellt ist.

  • Wählen Sie Ubuntu 64-Bit in Allgemein -> Grundlegend Einstellungen bei der Erstellung Ihrer VM

    enter image description here

  • Außerdem zum Laufen 64-Bit-Gäste Es wird empfohlen, den Input / Output APIC in der System -> Hauptplatine Einstellungen für Ihre virtuelle Maschine:

  • In dem System -> Beschleunigung In der Registerkarte können wir die Hardware-Virtualisierungsfunktionen VT-x / AMD-V Ihrer CPU aktivieren.

  • Auf dem Host-System müssen wir möglicherweise aktivieren Hardware-Virtualisierung im BIOS.

  • In einigen Systemen muss eine Host-BIOS-Option zum Verhindern einer nicht vertrauenswürdigen Ausführung deaktiviert werden (Quelle).


136
2018-06-16 20:47



es hat funktioniert: danke - aluph
es funktionierte wie Charme .. Vielen Dank. - Anil Chahal
Für mich ist sogar 'Ubuntu (64-bit)' nicht im Dropdown aufgelistet. Alle OS-Einträge im Dropdown-Menü zeigen '(32-Bit)' an. - ARUN
@ARUN hatten Sie die Virtualisierung im BIOS aktiviert? - Takkat
@ARUN Ich hatte das gleiche Problem. Beim Erstellen war es keine Option, aber nachdem es erstellt wurde, kannst du zurück zu Einstellungen> Allgemein gehen und es wird in dieser Liste sein. - Sinaesthetic


Öffnen Sie die Einstellungen für die virtuelle Maschine. Wechseln Sie zur Dropdown-Box Version (Allgemein> Standard> Version).

Wenn Sie "Ubuntu (64 Bit)" nicht als Option im Dropdown-Menü sehen, bedeutet dies, dass die Virtualisierung auf dem Host nicht aktiviert ist.

Starten Sie den Host neu, gehen Sie zum BIOS und aktivieren Sie die Virtualisierung. Verlasse das BIOS und stelle sicher, dass du die Änderungen speicherst.

Jetzt sollten Sie alle 64-Bit-Optionen in der Dropdown-Box Version sehen.

Virtual machine general settings


19
2018-01-26 20:55





Für diejenigen unter Ihnen, die wie ich sind und keine Option auf Ihrer virtuellen Box haben, um das zu wählen Version: Ubuntu (64 Bit):

Mach das: Laden Sie das 32-Bit-Ubuntu-iso herunter. INSBESONDERE, wenn Sie Ubuntu auf Ihrer virtuellen Box heruntergeladen haben, haben Sie weniger als 2GB Speicher zugewiesen.


5
2018-01-14 16:15





vboxmanage createvm --name "ubuntu" --ostype Ubuntu_64 --register

oder wenn Sie bereits erstellt haben,

vboxmanage modifyvm --ostype Ubuntu_64

Um den ganzen Typ aufzulisten: http://zeblog.co/?p=390


0
2018-05-29 17:57