Frage Ubuntu 16.04, die Installation von Updates hat einen Fehlercode zurückgegeben (1)


Ich habe routinemäßiges update && upgrade procedure auf Ubuntu 16.04 durchgeführt und wollte einige Multimedia-Codec-Bibliotheken aufrüsten

List of libraries to be updated

Ich habe das Upgrade wie auf dem Bild oben bestätigt. Der Upgrade-Prozess hat dann den Fehlercode (1) zurückgegeben und konnte das Upgrade nicht abschließen.

Broken Pipe, /usr/bin/dpkg returns an error code

Jetzt bekomme ich diese unerfüllte Abhängigkeits-Sache, wenn ich versuche etwas zu tun, was mit dem Upgrade zu tun hat.

The following packages have unmet dependencies:
 libavcodec-extra57 : Depends: libx265-102 (>= 2.2) but it is not installed
 x265 : Depends: libx265-102 (>= 2.2) but it is not installed
        Depends: libx265-102 (< 2.3) but it is not installed
E: Unmet dependencies. Try using -f.

Ich bin besorgt. Ist es möglich, in den Status zurückzukehren, bevor ich versuche, ein Upgrade durchzuführen?


2
2018-01-17 22:03


Ursprung


kann nicht mehr als 2 Links setzen, keine Bilder als Bilder ohne Links einfügen! Wenn mein Rep erhöht wird, werde ich den Beitrag bearbeiten. - Vemulo
Könnten Sie bitte Textdateien, Dialognachrichten und Programmausgaben als Text und nicht als Bilder programmieren? Um die letzten beiden zu erreichen, können Sie entweder 1) den Dialogtext oder den Terminalinhalt auswählen, kopieren und einfügen oder 2) Speichern Sie die Programmausgabe in einer Datei und benutze das. Längere Auflistungen (≥ 100 Zeilen) sollten in a hochgeladen werden Pastieservice und verlinkt in der Frage. Vielen Dank. - David Foerster
Mögliches Duplikat von Wie behebe ich nicht erfüllte Abhängigkeiten nach dem Hinzufügen eines PPA? - David Foerster
Ich habe das bearbeitet (da ich jetzt genug Rep), wenn der Inhalt der Endgeräte nicht reicht. Ich weiß nicht, was ich mehr tun kann. Weil ich es geschafft habe, mein Problem zu lösen, wie es in meiner eigenen Antwort heißt. Wenn Sie jedoch eine Erklärung haben, was passiert und warum dieser magische Befehl es löst. Ich bin immer noch interessiert zu wissen. Daher habe ich meine Antwort nicht als Antwort akzeptiert! - Vemulo
@DavidFoerster, danke für den Link. Es war eine umfangreiche Zusammenstellung von Lösungen für meine früheren (anderen) Probleme mit nicht erfüllten Abhängigkeiten. Mein Hauptproblem war jedoch der Fehler "Broken Pipe", den ich während des "Update" -Verfahrens bekommen habe. - Vemulo


Antworten:


Ich habe mein Problem gelöst, indem ich folgte dpkg überschreibt

Speziell habe ich eingegeben:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libx265-102_2.2-1~16.04.york0_amd64.deb

5
2018-01-18 20:59



Ich bin nicht hundertprozentig sicher, dass dies für alle ähnlichen Fälle sicher und anwendbar ist. Wenn jemand erklärt, was los ist und warum dieser Kommentar es gelöst hat. Ich kann es als Antwort akzeptieren. - Vemulo
Der obige Befehl löste dieses Problem auch für mich. - tomoqv


Versuchen wir zunächst, den "partiellen" Fehler zu beheben. Sei sehr vorsichtig mit diesen Befehlen:

sudo rm -vf /var/lib/apt/lists/partial/*  # Remove files in 'partial'
sudo rm -vf /var/lib/apt/lists/*  # Remove package lists in 'lists'
sudo apt-get update

Wenn Sie immer noch einen Statusfehler erhalten, versuchen Sie, eine Sicherungskopie der Datei wiederherzustellen:

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.0715
sudo cp /var/backups/dpkg.status.0 /var/lib/dpkg/status
sudo apt-get update

1
2018-01-18 17:25



Keine von ihnen hat gearbeitet. Ich bekomme immer noch die gleichen Fehler, leider! - Vemulo