Frage Ubuntu 16.04.3 Update GPG Fehler (öffentlicher Schlüssel nicht verfügbar) [Duplizieren]


Diese Frage hat hier bereits eine Antwort:

Ich benutze Ubuntu 16.04.3 LTS. Ich benutze es seit über einem Jahr und aktualisiere alle paar Monate ohne Probleme. Heute habe ich aktualisiert und ich habe diese seltsamen öffentlichen Schlüsselfehler. Ich habe keine Ahnung, was das bedeutet und wo ich anfangen soll.

Hier sind die Fehler:

Err:9 http://dl.google.com/linux/chrome/deb stable Release.gpg                 
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
Fetched 308 kB in 1s (159 kB/s)                                                
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error:      http://dl.google.com/linux/chrome/deb stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
W: Some index files failed to download. They have been ignored, or old ones used instead.

Ich habe bereits versucht, online zu recherchieren, habe aber festgestellt, dass die Erklärungen extrem verwirrend sind. Bitte hilf mir zu verstehen:

1) Was diese Fehler bedeuten.

2) Wie man sie repariert.


2
2017-08-05 18:10


Ursprung




Antworten:


Pakete in Repositories werden mit kryptografischen Schlüsseln signiert, um sicherzustellen, dass die heruntergeladenen Dateien von der Person erstellt wurden, von der Sie denken, dass sie sie ist (die Paketverwalter). Dies soll verhindern, dass ein Angreifer einen Spiegel kompromittiert und legitime Pakete durch Malware ersetzt und diese auf einer Reihe von Computern installiert.

Anscheinend haben Sie das Chrome-Repository von Google zu Ihrem System hinzugefügt. Sie scheinen eine Menge Probleme bei der Pflege zu haben, und bei meinem vorherigen Job kam es häufig zu diesem Fehler, bis Google den Spiegel reparierte (und dann wieder kaputt ging). Im Allgemeinen wird Ihr System stabiler, wenn Sie nur Software von den offiziellen Ubuntu-Repositories installieren. Vor allem, wenn man bedenkt, wie schlecht Google seinen Spiegel zu pflegen scheint, würde ich empfehlen:

  1. Deinstallieren von Chrome
  2. Das Repository wird entfernt.
  3. Installieren Chrom-BrowserDies ist die Open-Source-Codebasis, auf der Google Chrome basiert. Es sind nur ein paar Unterschiede.

2
2017-08-05 18:43



Lief wie am Schnürchen. - NewbieWanKenobi


Importieren Sie den neuen Repository-Schlüssel:

    wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

    sudo apt update

Du solltest gut gehen.


3
2017-08-05 18:59