Frage Unity lädt nicht, kein Startprogramm, kein Dash wird angezeigt


Wenn ich mich anmelde passiert nichts.

Ich werde mit meinem Desktop-Hintergrund dargestellt.

Blank desktops suck

Kein Dash, kein Launcher, nichts.


535
2017-12-14 17:24


Ursprung


IMHO das ist ein Fehler, aber ich habe das seit heute. Konnte nur diesen Fehler finden bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 Ich folgte den Empfehlungen hier: askubuntu.com/questions/17381/ ... Unity wurde zurückgesetzt, funktioniert aber nicht. OK, Arbeitsbereiche funktionieren nicht, auch wenn ich den Betrag aktiviere oder deaktiviere oder den Betrag ändere. Kein Unterschied. Put Plugin stürzt auch Einheit, - Janghou
Meine Probleme begannen nach dem Wechsel von Nouveau-Treibern zu NVIDIA-Treibern (Systemeinstellungen / Hardware-Registerkarte). - DanielaWaranie
Nach vielen Tagen und vielen gelesenen SO-Threads stellte ich fest, dass es sich um einen offenen Ubuntu-Bug handelt (Stand 'Incomplete' vom Juli 2015). Mehr Informationen dazu hier: bugs.launchpad.net/ubuntu/+bug/1285444  Die schnelle Lösung scheint zu sein: $ mv ~/.config/dconf/user ~/.config/dconf/user.old - xyz
@ julianromera's war die einzige Lösung in diesem Thread, die mir geholfen hat - Dziamid
@julianromera Antwort war die einzige, die für mich arbeitete. - Paweł Adamski


Antworten:


Diese Antwort gilt für Versionen von Ubuntu mit Compiz.

Diese Antwort geht davon aus, dass Unity über Compiz ausgeführt wird. Wenn Sie nicht haben compiz installiert Diese Antwort gilt nicht für Sie.

Sie müssen nur das Unity-Plugin wieder einschalten. Das Problem ist, dass es ein Problem ist, weil Sie jetzt keine grafische Methode dafür haben. Damit:

  1. Versuchen Sie ein Terminal mit zu öffnen Strg+Alt+T.
    Dies funktioniert möglicherweise nicht, aber Sie können versuchen, mit der rechten Maustaste auf den Desktop zu klicken und "Terminal hier öffnen" zu wählen. Andernfalls müssen Sie möglicherweise zu einem "harten" Terminal wechseln, indem Sie drücken Strg+Alt+F1 und logge dich ein.

  2. Installieren compizconfig-settings-manager durch Laufen

    sudo apt-get install compizconfig-settings-manager
    
  3. Dann führe es mit diesem aus:

    DISPLAY=:0 ccsm &
    

    Der erste Teil teilt dem Terminal mit, auf welcher Anzeige es geladen werden soll (sonst hat es keine Ahnung).

  4. Wenn Sie in Schritt 1 zu einem TTY gewechselt haben, wechseln Sie zurück zum graphischen Server, indem Sie drücken Strg+Alt+F7 (oder Strg+Alt+F8 manchmal).
    Dort sollte ein CompizConfig Settings Manager auf Sie warten.

  5. Finde das Unity-Plugin. Aktivieren Sie es. Sie werden gefragt "Ubuntu Unity Plugin benötigt das Plugin OpenGL. Aktivieren Sie Ubuntu Unity Plugin / Enable OpenGL"

  6. Alles sollte ins Leben kommen, aber wenn nicht, musst du vielleicht neu starten. Sie können das tun, indem Sie zum Terminal zurückkehren und das Programm ausführen sudo reboot.


465
2017-11-07 23:23



Arbeitete perfekt für mich. Als Randnotiz musste ich das TTY-Terminal nicht betreten, konnte das Terminal-Shortcut (ctrl + alt + t). - Tass
Wenn Sie zu Schritt 5 gelangen und die Einheit in der Liste nicht sehen, versuchen Sie Folgendes: sudo apt-get -f install && sudo apt-get --reinstall install unity - Collinux
Hatte dieses Problem selbst aber ich habe Pech mit der Lösung weit, funktioniert bei mir nicht, bekomme immer noch den gleichen leeren Bildschirm auf Ubuntu 14.04 LTS 64bit. Werde noch einmal über die Stufen gehen, um zu sehen, ob etwas verpasst wurde. Lenovo X201S Thinkpad i7 2.0 Ghz 8 GB RAM. Hatte dieses Problem nie mit 12.04 LTS - therobyouknow
Die Tatsache, dass das Problem so häufig und lang anhaltend ist, ist für mich eher störend. Weiß jemand, warum das so weitergeht und was es verursacht? - fouric
ccsm hängt beim Laden von Icons, aber wenn ich ctrl-alt-F7 zurück zum Haupt-Display, sind die Compiz-Optionen da. Ich habe den Unity-Desktop aktiviert, zurück zu tty1 (ccsm wurde erfolgreich ausgeführt) ... aber keine Unity. Neustart: keine Einheit. Wenn ich ccsm neu lade, ist Unity immer noch aktiviert und "on", aber es wird keine Unity angezeigt. - JeanSibelius


Eine gute Lösung für mich (hat das gleiche Problem gelöst):

in einem Terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

und dann

setsid unity

166
2018-05-04 00:50



Fantastisch. Arbeitet mit Ubuntu Linux 13.04 Desktop in Parallels unter Mac OS X. - Elliot
Vielen Dank! Funktioniert auch mit Ubuntu 14.04. Ich frage mich, warum das aus heiterem Himmel passiert ist :-( - Sadi
ich brauchte export DISPLAY=:0 zuerst. - Uri
sudo dconf reset -f / org / compiz / Fehler beim Erstellen der Befehlszeile 'dbus-launch --autholaunch = c0c0f8bf86119c64ccb710000000006 --binäre-syntax --close-stderr': untergeordneter Prozess mit Code 1 beendet - JeanSibelius
Ein Problem ist das Laufen dconf wie sudo machte mein ~/.config/dconf/user Datei haben root Besitz (es hatte mein Benutzereigentum vorher). Ich frage mich, ob es ohne gemacht werden sollte sudo. Das war viel besser, als die Datei zu entfernen und von vorne anzufangen! - Tim Tisdall


In 13.04 und 14.04:

unity --replace ist veraltet. Verwenden Sie stattdessen Folgendes:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Starten Sie neu, wenn es nicht sofort funktioniert.


72
2018-04-27 02:39



Dies funktionierte für mich nach der Installation geeigneter Treiber für meine Nvidia-Grafikkarte. Siehe meine Antwort askubuntu.com/questions/288235/ ... - Thomas Arildsen
dconf reset Befehl gibt Exitcode Fehler 1 und wird nicht arbeiten 13.10. - Peterdk
Aktivieren von Unity-Plugins mit ccsm einige der Probleme behoben, der Rest wurde behoben rm -r .Xauthority .ICEauthority .compiz-1/ .gconf/ .config/compiz-1/ .config/dconf/ - precise
D-Bus kann ohne X11 $ DISPLAY nicht automatisch gestartet werden. Bisher hat noch nichts geklappt - jimifiki
Es funktioniert auch für ubuntu 16.04, hat gerade mein Problem gelöst - Priyadarshi Paul


Für 12.10 und darunter:

Drücken Sie Strg+Alt+T für ein Terminal und Lauf ccsm, dann reaktiviere dein 'Unity' Plugin.

Sie müssen dann möglicherweise auch ein ausführen unity --replace.


60
2017-10-02 02:33



unity --reset ist jetzt veraltet und funktioniert nicht. Gibt es einen Ersatz? - Shahbaz
@ Shahbaz - unity --replace. - horIzoN
@ nerof61 wurde am 13.04 ebenfalls eingestellt. Siehe meine Antwort unten: askubuntu.com/a/286349/2638 - Brandon Bertelsen
weder --reset Noch --replace arbeitete für mich mit meinem Ubuntu 12.04 ..running die Befehle sofort angezeigt unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ... Ich wartete und wartete, und dann konnte ich nicht, unterbrochen mit Strg + C .. und jetzt versuchen, zu versuchen, was andere Antworten vorgeschlagen .. - precise


Es empfiehlt sich, zu überprüfen, ob der Grafiktreiber für die Hardwarebeschleunigung konfiguriert ist und ob OpenGL verwendet wird. Versuchen Sie es mit der Suche In den Ubuntu und Ubuntu Foren finden Sie Informationen zu Ihren GPUs und Ubuntus. Für hybride Grafik Benutzer sehen Sie den letzten Abschnitt "Hybrid Graphics" weiter unten.

Vielleicht möchten Sie das ausführen compizconfig-settings-manager  Install compizconfig-settings-manager package und stelle sicher, dass das Unity Plugin aktiviert ist (siehe Was sind einige der Probleme mit CCSM und warum sollte ich es vermeiden wollen?).

Für 12.04 Und Neuere

  1. Ändern tty1 durch Drücken Strg+Alt+F1 und logge dich ein.

  2. Installieren compizconfig-settings-manager durch Laufen

    sudo apt-get install compizconfig-settings-manager
    
  3. Führen Sie es dann folgendermaßen aus:

    export DISPLAY=:0
    ccsm
    

    Der erste Teil teilt dem Terminal mit, auf welcher Anzeige es geladen werden soll (sonst hat es keine Ahnung).

  4. Drücken Sie Strg+Alt+F7 (oder Strg+Alt+F8 manchmal), um zur grafischen Anzeige zurückzukehren, auf der sich ein CompizConfig Settings Manager-Bildschirm befindet.

  5. Finde das Unity-Plugin. Aktivieren Sie es. CCSM

  6. Alles sollte ins Leben kommen, aber wenn nicht, musst du vielleicht neu starten. Sie können das tun, indem Sie zurückgehen tty1und läuft sudo reboot.

Wenn die Einheit immer noch nicht geladen wird, versuchen Sie Folgendes:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Starten Sie neu, wenn es nicht sofort funktioniert.

Für 11.10 und älter

Wenn Sie auf eine TTY hoffen (Strg+Alt+F1 durch F6) und Renn:

DISPLAY=:0 unity --replace

Es wird Unity wieder auf TTY 7 zurücksetzen (Strg+Alt ++F7).

Sie können auch einfach versuchen:

DISPLAY=:0 unity

Aber das wird nicht funktionieren, wenn ein Windows-Manager bereits auf Anzeige 0 läuft (es wird Ihnen einen Fehler geben, einfach benutzen unity --replace In diesem Fall).

Wenn Unity absolut weigert sich neu zu starten versuche das:

Installieren gnome-panel:

sudo apt-get install gnome-panel

Dann führe es auf dem Display 0 aus:

DISPLAY=:0 gnome-panel

Sie sollten dann Gnome 2 Style-Panels auf Ihrem Desktop haben, mit denen Sie sich abmelden können.

Hybrid-Grafik

Einige sehr nützliche Informationen und weiterführende Informationen für hybride Grafikbenutzer können gefunden werden Hier.

Sobald GPUs entsprechend für 3D-Beschleunigung und OpenGL konfiguriert sind, können Sie:

  1. Installieren Sie Nvidia Treiber von https://edge.launchpad.net/~xorg-edgers/+archive/ppa:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    oder:

    Ich würde wirklich das bevorzugen stabiles PPA, aber es scheint noch keine Pakete für 13.04 zu haben. Update: Diese scheinen ab 25. September verfügbar zu sein. Ich würde dieses stabile PPA installieren - Sie können es versuchen, aber ich habe es nicht getestet.

    Die von Ubuntu gelieferten Nvidia-Treiber wurden bereits installiert und ich habe einfach von diesem PPA installiert, indem ich es hinzugefügt und ein Paketupdate mit gemacht habe update-manager.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installiere Bumblebee von https://launchpad.net/~bumblebee/+archive/stable

    UPDATE: Ab dem 6. Oktober ppa:xorg-edgers/ppa scheint auch Hummel zu enthalten. Wenn Sie also von diesem PPA installieren, sollten Sie versuchen, das Hinzufügen des Bumblebee PPA zu überspringen und stattdessen von hier aus zu installieren.

    Wenn Sie das stabile PPA in Schritt 1 ausgewählt haben, installieren Sie das stabile Bumblebee-PPA wie folgt:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: Aktualisieren Sie nach dem Hinzufügen der PPA (s) Ihre Paketlisten:

    sudo apt-get update
    

    Wenn Sie bereits Nvidia-Treiber aus den Standard-Repositorys von Ubuntu installiert haben, führen Sie einfach ein Upgrade durch, um die neue Version aus dem in Schritt 1 ausgewählten Repository zu erhalten:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Führen Sie die folgenden Befehle aus, um Unity zu reparieren (von Brandon-BertelsenAntwort auf Unity lädt nicht, kein Startprogramm, kein Dash wird angezeigt):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    

51
2017-12-27 12:45



In 14.10: unity --reset-icons & disown gibt mir halt: Unbekannter Job: unity-panel-service // start: Unbekannter Job: unity-panel-service // compiz (kern) - Info: Plugin laden: core // compiz (Kern) - Info: Start Plugin: Core ... und keine weitere Aktion. Alt-F7 bringt mich zurück zur Grafik, wo ich ein Seitenmenü, aber kein "Start" -Menü habe (nichts im oberen Menü - kein Verbindungssymbol, Power-Icon, etc. - zurück zu tty1 gibt mir Bildschirme und Bildschirme mit Informationen. .. reboot und ich bin wieder im Geschäft! DANKE FÜR DEIN MAGIC VOODOO - JeanSibelius
Ihr Abschnitt "Für 12.04 und neuer" funktioniert nicht auf Ubuntu 16.04. - Luís de Sousa
apt-Hinzufügen-Repository? - fehlt - Kalpesh Soni


Der einfachste Weg ist das Drücken von Strg+Alt+T ein Terminal bekommen und dann ausgeben:

rm -rf ~/.compiz-1 ~/.config/compiz-1

und deine Einheitssitzung wird vor deinen Augen zurückkommen.

Diese Technik ist besser als das erneute Starten von ccsm, weil Sie in den Fehlerzustand von OP gelangen können, ohne versehentlich die Einheit in ccsm auseinandernehmen zu müssen; Sie können es einfach erhalten, indem Sie versehentlich auf die Schaltfläche "Einstellungen" in ccsm drücken.


32
2017-11-10 05:55



Ich vermute du meinst .config / compiz-1 - matteo
Ich kann ctrl-alt-T nicht verwenden - jimifiki
@jimifiki: drücke 'crtl' + 'alt' + 'f1' und mache dann, was achiang vorgeschlagen hat. obwohl ich persönlich sie aus dem Weg bewegen würde, wenn Sie mehr Probleme finden. - isaaclw
@isaaclw Ich tat was vorschlägt. Nichts hat sich verändert. Bemerkenswerterweise funktioniert die Gastsitzung normal. - jimifiki
Für mein Ubuntu 16.04 waren die relevanten Dateien zu entfernen .cachenicht .config. Damit rm -rf ~/.cache/compizconfig-1 hat für mich gearbeitet. - tparker


Ich hatte dieses Problem auch. Ich löste es, indem ich den Inhalt der Datei ~ / .config / compiz-1 / compizconfig löschte und relog.

rm -rf ~/.config/compiz-1/compizconfig/*

25
2017-10-30 06:23



funktionierte nicht für mich, so ziemlich wie alles andere auf dieser Seite - matteo
Ja! Danke, es hat funktioniert! Ich habe Ubuntu 16.04 in VirtualBox installiert und nach einem der Updates habe ich dieses Problem. Dies ist die einzige Lösung, die für mich funktioniert hat! Oh, und vergessen Sie nicht, nach der Anwendung dieses Fix neu zu starten. - informatik01
Funktioniert nicht auf Ubuntu 16.04. - Luís de Sousa
Habe am 16.04 nicht für mich gearbeitet - 43Tesseracts
Für mein Ubuntu 16.04 waren die relevanten Dateien zu entfernen .cachenicht .config. Damit rm -rf ~/.cache/compizconfig-1 hat für mich gearbeitet. - tparker