Frage shotwell 0.12 shared library error [geschlossen]


ich installierte Shotwell 0.12 so über seine offizieller PPA

sudo add-apt-repository ppa:yorba/ppa
sudo apt-get update
sudo apt-get install shotwell

und als ich versuchte, es über den strich zu starten, fing es nicht an.
Ich tippte dann in den Gnome-Terminal "Shotwell" Ich habe dann diesen Fehler bekommen

error while loading shared libraries: libgexiv2.so.0: cannot open shared object file: No such file or directory

Meine Frage ist, wie man Shotwell 0.12 in ubuntu 11.10 amd64 zum laufen bringt


2
2018-03-28 08:25


Ursprung


Dies sieht wie ein neuer Fehler aus, der heute beginnt. Ich benutze den gleichen PPA und 64-Bit 11.10. Ich kann Shotwell überhaupt nicht öffnen. - Tom Brossman
hast du auch Dunkeltisch Eingerichtet? Ich tue es und bekomme 'nicht gefundene Abhängigkeiten' Fehler mit diesem Paket, wenn ich versuche, die Bibliothek neu zu installieren. - Tom Brossman
Können Sie Shotwell aktualisieren und testen, ob es wieder funktioniert? Wenn ja, sollten Sie eine der folgenden Antworten akzeptieren. Wenn nicht, aktualisieren Sie Ihre Frage. Alles sollte jetzt funktionieren. - Tom Brossman
Ich habe Shot-Well upgedated und alles funktioniert super. Ich akzeptierte die Antwort von Adam Dingle - blade19899


Antworten:


Wir haben Shotwell 0.12 gestern veröffentlicht und leider ist der 64-Bit Build auf dem Yorba PPA fehlgeschlagen (obwohl der 32-Bit Build gut funktioniert hat). Wir wissen noch nicht warum:

http://redmine.yorba.org/issues/4949

Dies zu untersuchen ist unsere oberste Priorität. Ich erwarte, dass wir das innerhalb eines Tages oder so haben. Danke für Ihre Geduld!

Adam Dingle, Yorba-Stiftung


2
2018-03-28 17:53



Es funktioniert wieder, danke. - Tom Brossman


Es scheint ein Problem mit Oneiric 64-Bit zu geben. https://launchpad.net/~yorba/+archive/ppa/+build/3323887

Ich habe auch den gleichen Fehler, versucht, Shotwell und notwendigen Bibliotheken neu zu installieren, einschließlich von Grund auf neu (+ Bibliotheken), aber ohne Glück.


1
2018-03-28 17:48





Vom Terminal aus

Versuchen Sie, libgexiv zu installieren: sudo apt-get install libgexiv*


1
2018-03-28 13:27



Ich habe einen Fehler der .dbg-Paket den Rest ich installiert noch Shotwell hat nicht funktioniert. Dies ist der Fehler für das .dbg-Paket Die folgenden Pakete haben noch nicht abgeschlossene Abhängigkeiten: libgexiv2-0-dbg: Hängt davon ab: libgexiv2-0 (= 0.3.1-0ubuntu2) aber 0.4.0-0oneiric1 wird installiert E: Probleme konnten nicht behoben werden , du hast kaputte Pakete gehalten. Ich habe eine niederländische Version von Ubuntu, den Fehler, den ich mit Google Translate übersetzt habe. - blade19899


Ich habe libgexiv2-0 entfernt: sudo apt-get purge libgexiv2-0

Dann neu installiert Shotwell: sudo apt-get install shotwell 

Und das hat mein Problem gelöst.


1
2018-01-05 22:47



Dies funktionierte auch für mich, auf Ubuntu 12.10 mit dem yorba PPA. - Jim Garrison