Frage Banshee hört nach einem Song auf zu arbeiten


Ich kann keinen wirklichen Grund finden, warum Banshee aufhört zu spielen und nach 1 Song abstürzt (manchmal nach 2/3/4 Songs, aber 90% nach 1 Song und auf den ersten paar Sekunden des zweiten Songs). Shuffle an / aus ist nicht wirklich wichtig. Ich versuchte zu      sudo apt-get clean entfernen Banshee      rm -rf ~ / .config / banshee-1      sudo apt-get installieren Banshee Habe aber immer noch dasselbe Problem.

banshee --debug Ausgabe: Normallied (1.):

[1 Debug 01:25:56.790] (libbanshee:player) bp_stop: setting state to GST_STATE_NULL
[1 Debug 01:25:56.826] Player state change: Playing -> Idle
[1 Debug 01:25:56.828] Player state change: Idle -> Loading
[1 Debug 01:25:56.924] Player state change: Loading -> Loaded
[1 Debug 01:25:56.926] (libbanshee:player) [gapless] Triggering track-change signal
[1 Debug 01:25:56.927] Player state change: Loaded -> Playing
[1 Debug 01:25:57.942] TrackInfoDisplay RenderAnimation: 32.00 FPS

2. Lied:

[1 Debug 01:26:02.151] Querying model for track to play in song:Next mode
[1 Debug 01:26:02.162] (libbanshee:player) bp_stop: setting state to GST_STATE_NULL
[1 Debug 01:26:02.202] Player state change: Playing -> Idle
[1 Debug 01:26:02.204] Player state change: Idle -> Loading
[1 Debug 01:26:02.317] Player state change: Loading -> Loaded
[1 Debug 01:26:02.319] (libbanshee:player) [gapless] Triggering track-change signal
[1 Debug 01:26:02.327] Opening http://en.wikipedia.org/wiki/Beck
[1 Info  01:26:02.352] Uncached artwork size 37 requested
[1 Debug 01:26:02.353] Player state change: Loaded -> Playing
Stacktrace:

  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x0000e, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at Banshee.Gui.GtkBaseClient.Run () <IL 0x0000d, 0x0005f>
  at Banshee.Gui.GtkBaseClient.Startup () <IL 0x0000f, 0x00049>
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) <IL 0x00045, 0x0008e>
  at Banshee.Gui.GtkBaseClient.Startup<T> () <IL 0x00036, 0x0006b>
  at Banshee.Gui.GtkBaseClient.Startup<T> (string[]) <IL 0x0004d, 0x000ff>
  at Nereid.Client.Main (string[]) <IL 0x00001, 0x00017>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <IL 0x00050, 0xffffffff>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly (System.AppDomain,System.Reflection.Assembly,string[]) <IL 0x0001b, 0xffffffff>
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly,string[]) <IL 0x0002f, 0x00047>
  at System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) <IL 0x0000b, 0x00037>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) <IL 0x0003b, 0xffffffff>
  at System.AppDomain.ExecuteAssembly (string) <IL 0x00004, 0x0001f>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string) <IL 0x00039, 0xffffffff>
  at Booter.Booter.BootClient (string) <IL 0x00024, 0x0006b>
  at Booter.Booter.Main () <IL 0x000f6, 0x001db>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <IL 0x0004c, 0xffffffff>

Native stacktrace:

    banshee() [0x4961e9]
    banshee() [0x4e6d1f]
    banshee() [0x41dcb7]
    /lib/x86_64-linux-gnu/libpthread.so.0(+0xfbd0) [0x7ffd5f623bd0]

Debug info from gdb:

Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted

SW:

# uname -a
Linux drey-ISP-note 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
# cat /etc/issue
Linux Mint 15 Olivia \n \l

HW: ASUS K56B


2
2017-12-23 16:28


Ursprung




Antworten:


Ich habe eine Problemquelle gefunden - Wiki-Erweiterung. Wenn ich Wiki deaktiviere, ist alles in Ordnung. Im Menü:

Edit -> Preferences -> Extensions -> unmark Wikipedia -> OK

Aber die Frage ist - warum verhält es sich so und wie können wir es reparieren?


1
2017-12-23 16:34



Ich würde vermuten, dass Banshee versucht, eine Verbindung zu Wikipedia herzustellen, um Künstlerdaten zu finden und sie nicht zu finden oder an einem Netzwerkausfall zu hängen. Das hat es aber für mich repariert, danke. - Jim Kiley


Ich hatte das gleiche Problem wie das OP. Zuerst dachte ich, dass das Deaktivieren der Wiki-Erweiterung es beheben würde, weil ich in der Lage war, zu einem anderen Lied zu kommen, aber irgendwann hörte es auch wieder auf, als es auf eine andere Spur wechselte. Mein nächster Schritt war, die Updates zu überprüfen, und ich sah eine neue Version des Netzwerk-Manager-Pakets. Nachdem ich das installiert hatte, funktionierte Banshee wieder gut für mich, ohne Probleme.


1
2017-12-08 00:30





Gehe zu Bearbeiten> Einstellungen und ausschalten Aktivieren Sie die lückenlose Wiedergabe

Das hat für mich funktioniert.


1
2017-09-06 19:47