Frage Wie kann ich eine ältere Version von Firefox in Ubuntu 14.04 installieren?


Ich habe Ubuntu 14.04 installiert, welches bereits Firefox v31 enthält. Ich möchte eine ältere Version von Firefox installieren. Wie kann ich es tun?


16
2017-08-02 14:20


Ursprung


Warum nicht einfach eine ältere Version von Firefox von der Firefox-Website herunterladen? Sie haben .deb-Pakete für die meisten ihrer Versionen. - Alvar
Einige Benutzer werden diesen Beitrag finden, weil sie einige weniger beliebte Funktionen in Firefox wie DRM-Integration (EME) vermeiden und unsignierte Erweiterungen nicht zulassen möchten. Einige Benutzer mögen diese Änderungen und manche nicht. In diesen Fällen - und eigentlich in allen Fällen - ist es besser, einen anderen Browser zu verwenden als eine nicht unterstützte Firefox-Version, die keine Updates erhält. Das Ausführen eines alten Browsers, der keine Sicherheitsupdates enthält, ist ein großes Risiko! Eine unterstützte Version eines Firefox Gabel  wie Waterfox ist eine bessere Wahl als eine nicht unterstützte Version eines Browsers. - Eliah Kagan


Antworten:


Diese Seite hat alle Deb-Pakete von Firefox von 3.5 auf die neueste Version.


10
2017-08-06 13:06



Macht es Ihnen etwas aus, diese Antwort als richtig zu markieren? [1]:askubuntu.com/users/311588/user311588 - AliReza Mosajjal
Seien Sie gewarnt: Ein gruseliger Teil ist, dass es stillschweigend die ebenfalls installierte Version 52 überschreibt (ich brauchte es, um Zugriff auf mein Firmen-VPN zu haben, also war mir das nicht wirklich wichtig) - gkephorus


Um zwei oder mehr Versionen von Firefox zu verwenden (die vielleicht einige ältere Versionen haben).

Laden Sie die ältere Version von Firefox aus dem Archiv herunter: Mozilla.org_ftp_site

Entpacken Sie irgendwo.

Öffnen Sie als nächstes das Terminal und verwenden Sie den folgenden Befehl, um einen neuen Firefox-Benutzer hinzuzufügen.

firefox --no-remote -P

Erstellen Sie einen neuen Benutzer, notieren Sie sich den Benutzernamen. (Verschiedene Benutzer haben eindeutige Benutzerdaten, Lesezeichen usw.)

Als nächstes erstellen Sie einen Launcher für die "Firefox" entpacken Sie einfach. Gehen Sie in den entpackten Ordner, dort finden Sie eine Firefox-Datei (binär), die das Programm startet. Aktualisieren Sie den Befehl beim Erstellen des Startprogramms wie folgt:

/path/to/unzipped/firefox --no-remote -P "<user-name>"

Verwenden Sie den Link zum Erstellen eines Startprogramms: Erstellen von Launcher in Ubuntu

Und jetzt, mit diesem Launcher kann die neu heruntergeladene Version von Firefox verwendet werden. Wichtig - Überprüfen Sie die zu überprüfende Build-Version.

In der URL-Leiste about:  um die Build-Version zu überprüfen.


9
2018-05-11 13:39





Wenn du eine ältere Firefox-Version installieren willst (und ich wage zu raten, dass die neue australis-Benutzeroberfläche?), Benutze zumindest die Firefox-ESR-Version.

Firefox-ESR = Firefox Extended Support Release, und zumindest haben Sie die neuesten Sicherheitsupdates.

Sie können die neueste Firefox-ESR-Version von der Offizielle Firefox-Seite.

Alternative:

Ich habe für diese Zielgruppe einige Quellen erstellt, die auf github gehostet werden. Sie können den entsprechenden herunterladen und ausführen. (Klicken Sie auf die Schaltfläche "Raw", um das Skript herunterzuladen.)

Die Skripte benötigen Root-Rechte, um sie auszuführen, da sie einige Dateien herunterladen und schreiben /opt/ Verzeichnis.

Wenn Sie das Skript lesen möchten, bevor Sie es ausführen (und das ist immer eine gute Sache), können Sie dies mit einem Texteditor (wie gedit oder nano) oder direkt auf der github-Seite tun.

Die GitHub-Seite ist hier.


4
2017-08-02 15:19



Danke vielmals! Ich habe einen dieser "mozilla builds" (deb packages) installiert und es würde nicht starten. Anders als beng ein bisschen hinter ESR ist genau das gleiche wie die entsprechende Nicht-ESR-Version richtig? - Bleep Bloop
Danke noch einmal. Die neuesten 50.x-Versionen in Ubuntu 14.04 (LTS) + VirtualBox aus irgendeinem Grund brach Fehler in der Konsole geworfen, so dass ich stumme Fehler anstelle der Warnungen von VueJs geworfen bekommen würde. Stelle dir das vor. Funktioniert einwandfrei auf dem Windows 7-Host, dieselbe Firefox-Version. Diese ESR-Version behebt das Problem. (Außerdem sind die neuen "eingebauten" Entwicklerwerkzeuge träge, das Firebug-Addon ist schneller> _>). - Bleep Bloop


Überprüfen Sie diesen Link: Mozilla FTP-Site. Sie können Ihre gewünschte Version herunterladen, beachten Sie jedoch, dass dies keine .deb-Dateien sind. Sie müssen die .tar.gz-Dateien extrahieren und die .tar.gz-Datei ausführen firefox binär.


3
2017-08-02 15:00



Was ist eine Firefox-Binärdatei? Sagst du, dass die Deb im Teer ist? oder sagst du, dass es wie der tarball wie blender hat .. wo es in einem directory selbst enthalten ist. - Bhikkhu Subhuti
Versuche dies ftp.mozilla.org/pub/firefox/releases/49.0b4/linux-x86_64/en-US/.... Extrahiere die gezippte Datei und starte sie $./firefox aus dem Verzeichnis heraus. - Swarnendu Biswas
Danke .. Ich habe die nächste Antwort gefunden (auf dieser Seite) um mir zu helfen. Ansonsten, wenn ich auf Firefox geklickt habe, habe ich die gleiche Version von Firefox, die zuvor installiert war, dh. das neueste). Erstellen eines Benutzers war die Lösung. Am Ende funktionierte die digitale Pali-Reader-Erweiterung in Firefox noch nicht. Ich stellte sie zur Verfügung, indem ich mit der rechten Maustaste auf die Menüleiste klickte und "Palette anpassen" hinzufügte. Dann war ich am Laufen. Dies funktionierte auch in der letzten aktuellen Version. Vielleicht hilft das bei den Problemen anderer Leute. BTW .. Sie können auch eine Menüleiste auf diese Weise bekommen. - Bhikkhu Subhuti


Für Ubuntu Trusty und Xenial existiert neu Jonathon Fs PPA.

sudo add-apt-repository ppa:jonathonf/firefox-esr
sudo apt-get update
sudo apt-get install firefox-esr

Es ist vielleicht sehr nützlich wegen der neuen Add-On-Richtlinie für Firefox.
Ich habe 10 Add-ons installiert und 9 von ihnen sind als markiert ERBE.


2
2017-09-09 19:30



Debian hat das firefox-esr Paket, aber Ubuntu nicht. Vielleicht möchtest du dafür abstimmen LaunchPad-Fehler 1676164. - N0rbert


Hier sind einige klare Anweisungen zum Herunterstufen auf eine ältere Version von Firefox in Ubuntu 12.04. Ich habe es getan und es hat gut funktioniert. Jetzt, da ich mein Ubuntu auf 14.04 aktualisiert habe, zieht Firefox 31.0 wie verrückt durch ... sehr langsam und reagiert nicht. Also mache ich mich bereit, dies mit 14.04 zu versuchen. Ich sehe nicht, warum es am 14.04 nicht funktionieren würde.

Hier ist der Link https://www.liberiangeek.net/2012/04/how-to-install-previous-versions-of-firefox-in-ubuntu-12-04-precise-pangolin/

Eine Vorsichtsmaßnahme. Fast unmittelbar nachdem die ältere Version gestartet wird, wird sie wahrscheinlich automatisch auf die neueste Version aktualisiert! Sobald Sie die ältere Version starten, müssen Sie auf Bearbeiten> Einstellungen> Erweitert Schaltfläche> Registerkarte Update gehen ... und deaktivieren Sie das Kontrollkästchen "automatisch neuste Version herunterladen". Wenn Sie nicht schnell genug dazu kommen, konnte ich nicht herausfinden, wie Sie den Download und die Installation unterbrechen können. Ich habe es erneut versucht und bin einfach schneller gegangen und habe die Box deaktiviert, bevor sie das Upgrade starten konnte und es funktionierte.

Es ist alles Terminal-Befehle, also nehme ich an, wenn es am 14.04 nicht funktioniert, wird ein schlechter Befehlsfehler mich / Sie wissen lassen.


0
2017-08-17 01:09