Frage Wie konfiguriere ich PyQt4 für Python 3 Eclipse in Ubuntu?


Ich habe PyQt4 mit Synaptic installiert.

Ich benutze Python3, also muss ich den Pfad für PyQt4 in Eclipse konfigurieren, aber es scheint synaptisch installiert nur PyQt4 für Python 2, da ich nur relative Dateien und Ordner unter Python 2.6 und 2.7 gefunden.

Also wie kann ich machen PyQt4 arbeiten mit Python 3 und Finsternis ?

Vielen Dank.

AKTUALISIEREN:

Ich habe versucht, es nach diesem Post zu konfigurieren: http://ubuntuforums.org/showthread.php?p=10914908#post10914908

Aber nachdem ich alle Anweisungen befolgt habe, ohne dass irgendein Fehler in der Art und Weise aufgetreten ist, bekomme ich einen Fehler bei der Ausführung dieses Codes in Python 3.2:

>>> import PyQt4

Die Fehlermeldung lautet:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named PyQt4

Aber die seltsame Sache ist, dass der gleiche Code KEIN Fehler in Python 2.7 (Ich habe sowohl 2.7 und 3.2 auf meinem Rechner installiert)


2
2017-10-29 14:21


Ursprung




Antworten:


Sollte möglich sein. Die Quelle sitzt bei Website des Riverbank. Es könnte jedoch kein One-Line-Deal sein, aber es sollte funktionieren. Schau dir a an fädle dich über das ubuntuforum wo eranga1988 hatte ein ähnliches Problem.

Weiter unten in diesem Thread scheint CoBrA2168 eine Lösung zu geben:

  • Laden Sie SIP und PyQt4 von der offiziellen Website herunter
  • Installieren Sie qmake, python3.1-dev, gcc-c ++ (für den Befehl g ++) und libqt4-dev.
  • dann arbeitete die Zusammenstellung in den folgenden Zeilen

    python3.1 configure.py

    make

    sudo make install

  • Beachten Sie, dass einige den Aufruf von qmake zum Aufruf von Python oben bereitstellen mussten:


2
2017-11-15 05:54





Installieren Sie Python3-Bindungen für Qt4. In Ubuntu 12.04 und darüber hinaus öffne das Terminal und tippe:

sudo apt-get install python3-pyqt4

0
2017-09-03 12:25