Frage Die Einheit beginnt nicht, obwohl sie mehrere Monate gearbeitet hat


Mein Computer konnte Unity ohne Probleme laufen lassen, seit ich vor ein paar Monaten 11.04 installiert habe. Das unity_support_test Skript haben zuvor immer ein klares Ja zur Frage gegeben, ob Unity unterstützt wird. Meine Grafikkarte ist eine NVIDIA GeForce GT 330M und ich habe die proprietäre Treiberversion 270.41.06 installiert.

Allerdings startete Unity heute nicht, als ich meinen Computer startete und mich anmeldete, stattdessen bekam ich die "Ubuntu classic" -Schnittstelle. Ich habe ein paar Mal neu gestartet und bin extra vorsichtig gewesen, "Ubuntu" als Session zu wählen und nicht "Ubuntu Classic" oder irgendeine andere Nicht-Unity-Alternative, aber das Ergebnis ist jedes Mal dasselbe, Ubuntu Classic und keine Unity.

Es gab gestern einige Updates, aber ich habe nichts Interface-bezogenes erkannt.

Ich habe einige andere Fragen und Antworten hier gelesen, aber ich habe nichts nützliches gefunden. Die einzige Empfehlung, die ich befolgt habe, war, den CompizConfig-Einstellungsmanager zu installieren und zu überprüfen, ob das Ubuntu Unity-Plugin aktiviert wurde, aber das Plugin war bereits so aktiv, wie es sein sollte.

Als letzte Überprüfung vor dem Posten dieser Frage habe ich die unity_support_test Skript und zu meiner Überraschung war die Antwort nicht "Ja", sondern stattdessen das Folgende:

mghg@vaio-ubuntu:~$ /usr/lib/nux/unity_support_test -p
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  138 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x1ff
  Serial number of failed request:  31
  Current serial number in output stream:  31

Bitte hilf mir, zur Unity zurückzukehren!


2
2017-08-24 17:30


Ursprung




Antworten:


Neuinstallation der Treiber behebt das Problem.


2
2017-08-24 18:22



Danke, Neuinstallation des Grafiktreibers indead hat das Problem gelöst. Allerdings habe ich zum ersten Mal bei der Installation eines Grafiktreibers folgende Fehlermeldung erhalten ERROR: File '/usr/lib/xorg/modules/extensions/libglx.so' is not a symbolic link. Warum ist das erschienen? - mghg