Frage Fehler beim Versuch, das Java SDK zu installieren


Ich muss das Java 6 SDK installieren, aber nachdem ich folgendes ausgeführt habe:

sudo apt-get install sun-java6-jdk sun-java6-jre sun-java6-source

Ich komme damit auf:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
sun-java6-jdk : Depends: sun-java6-bin (>= 6.26-1lucid1) but it is not going to be                   installed
sun-java6-jre : Depends: sun-java6-bin (>= 6.26-1lucid1) but it is not going to be  installed or
ia32-sun-java6-bin (>= 6.26-1lucid1) but it is not installable
Recommends: gsfonts-x11 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ich bin ziemlich neu bei Ubuntu und brauche die Pakete für meinen Kurs. Ich schätze, sie sind korrupt geworden, aber wie kann ich das beheben?


2
2017-11-14 17:37


Ursprung




Antworten:


Es sagt, dass es nicht sun-java6-bin hat, was eine Abhängigkeit ist, also installiere das auch. Ändern Sie Ihren ursprünglichen Befehl zu:

sudo apt-get install sun-java6-jdk sun-java6-jre sun-java6-source sun-java6-bin

1
2017-11-14 17:55