Frage Dell XPS 9360 Externer Monitor verursacht seltsame Farben


Ich habe heute meinen dell xps 13 Entwickler in einen Projektor gesteckt und das Ergebnis war so etwas wie 8 Farbbits, man sieht es hier:

enter image description here

Ich habe das gleiche Problem, wenn ich es an meinen 46 "Fernseher anschließe. Wenn ich es verbinde und dann den Fernseher aus- und wieder einschalte, sind die Farben korrekt.

Es funktioniert auch, wenn ich es an meine 24 "externe Dell-Anzeige anschließe. Hat jemand so etwas erlebt?

Der Adapter, den ich verwende, ist dieser: https://www.startech.com/eu/AV/usb-c-video-adapter/usb-c-hdmi-adapter-CDP2HD

Die Ausgabe von xrandr ist:

Screen 0: minimum 320 x 200, current 5120 x 1800, maximum 8192 x 8192 eDP-1 connected primary 3200x1800+0+0 (normal left inverted right x axis y axis) 294mm x 165mm 3200x1800 59.98*+ 47.99
2048x1536 60.00
1920x1440 60.00
DP-1 connected 1920x1080+3200+0 (normal left inverted right x axis y axis) 1060mm x 626mm 1920x1080 60.00*+ 50.00 59.94 30.00 25.00 24.00 29.97 23.98
1920x1080i 60.00 50.00 59.94
1680x1050 59.88
1600x900 60.00
1280x1024 75.02 60.02 .... 720x400 70.08
HDMI-1 disconnected (normal left inverted right x axis y axis) DP-2 disconnected (normal left inverted right x axis y axis) HDMI-2 disconnected (normal left inverted right x axis y axis)

Ist es ein Problem, dass der Monitor als DP-1 anstelle von HDMI-1 erkannt wird? Dell XPS 13 Entwickler Kaby Lake. Ich habe es mit versucht Ubuntu 16.04 und Ubuntu 16.10 mit Kernel 4.4.0-59-generic und 4.8 und 4.9.


2
2018-01-30 19:03


Ursprung


Ich habe genau das gleiche Problem, habe Ubuntu 14.04 (vorinstalliert) und Ubuntu 16.04.2 ausprobiert. Ich benutze den Adapter ebay.co.uk/p/ Aber ich erinnere mich, dass dieser Laptop in der Vergangenheit mit anderen Adaptern bei einer Konferenz funktioniert hat. - giorgiosironi
Meine dmesg-Ausgabe ist um gist.github.com/anonymous/63f12c7827957bc964846553991be765 - giorgiosironi
bugs.launchpad.net/ubuntu/+source/linux-hwe-edge/+bug/1661987 - giorgiosironi
bugs.freedesktop.org/show_bug.cgi?id=99137 - giorgiosironi


Antworten: