Frage Ubuntu 13.10 Kioskmodus mit benutzerdefinierter Sitzung funktioniert nicht


Ich habe Ubuntu 13.10 installiert und versuche gleich beim Booten in den Kiosk-Modus zu gelangen, aber nichts funktioniert.

Ich benutze diese Methode (http://nexxylove.tumblr.com/post/22690398464/ubuntu-web-kiosk-in-10-easy-steps)

Create ~/.xsession, add the following;
#!/usr/bin/env bash
chromium-browser

Wenn ich dann startx im Terminal starte, wird nur der Desktop aktualisiert und Chrom erscheint nicht.

Ich habe auch die Methode mit angepasster Sitzung versucht:

1) Open a file (gksu gedit /usr/share/xsessions/Firefox.desktop) and paste:
[Desktop Entry]
Name=Firefox (No effects)
Comment=This session only opens Firefox
Exec=/usr/bin/firefox -height 1200 -width 1600
Icon=
Type=Application

Aber es funktioniert auch nicht. Wenn ich auf diese Datei klicke, erscheint chrome (ich habe die Namen geändert). Was mache ich falsch? Ich habe fast 3 Stunden damit verbracht und versucht, es zu lösen, gefolgt von vielen Tutorials.


Ok, habe es herausgefunden. Ich habe /.xsessionrc anstelle von .xsession erstellt und jetzt funktioniert es einwandfrei.


2
2018-04-14 13:48


Ursprung


Ok ich habe was. Wenn ich die erste oben beschriebene Methode verwende, gehe in die Konsole mit ctrl + alt + f1 und melde mich dann bei meinem Kiosk-Benutzer an und führe startx aus, es geht ohne Probleme in den Chrome-Browser. Was kann die Ursache dafür sein? - user268816
Gibt es einen Grund, warum Sie den integrierten Startup-Manager nicht verwenden können? Vielleicht interessieren Sie sich auch für die --kiosk Flagge für Chrom. - saiarcot895
Der Startup-Manager funktionierte nicht für mich und ich möchte den Benutzer darauf beschränken, nur den Browser zu verwenden. Ich benutze Kiosk-Flag, nur dieses Skript hier wurde vereinfacht, um es einfach zum Laufen zu bringen. - user268816
Ich versuche eine ähnliche Sache zu machen. In meinem speziellen Fall bekomme ich einen Fehler: Xsession: unable to launch "/path/to/script argument" X session --- "/path/to/script argument" not found; falling back to default session. Dies sagt mir, dass Ubuntu versucht, eine Datei zu finden script\ argument beim /path/to/, was ich nicht will. Seltsamerweise habe ich es ohne ein Argument arbeiten, und gnome-session --session=ubuntu funktioniert wie vorgesehen, aber nicht was ich brauche. - MishaP


Antworten: